Photoshop II

Table of Contents

Photoshop II ........................................................................................................................ 1
Table of Contents ............................................................................................................ 1
Introduction ..................................................................................................................... 1
Brushes ............................................................................................................................ 1
Selections .......................................................................................................................... 5
  The Marquee Tools ..................................................................................................... 5
  The Magic Wand Tool ............................................................................................... 7
  The Lasso Tools ......................................................................................................... 8
Combining Tools ............................................................................................................. 10
  The Select Menu ....................................................................................................... 11
Masks & Extractions ....................................................................................................... 13
  Quick Mask Mode ...................................................................................................... 13
  Mask Channels from Your Image ............................................................................... 15
Extractions .................................................................................................................... 18
Fun with Selections & Masks ........................................................................................ 20
Filters .............................................................................................................................. 25
  Corrective Filters ...................................................................................................... 26
  Effects Filters ............................................................................................................. 30
Layers .............................................................................................................................. 34
Closing ............................................................................................................................. 38
Resources ......................................................................................................................... 38

Introduction

Once you’ve got an understanding of Photoshop’s interface, and how you can use the program for basic image corrections, you’re ready to explore the more sophisticated image editing tools available in the program. We’re going to take a closer look at Photoshop’s brushes, which can be used to paint in your image. We’ll also examine the selection tools, which can help you isolate the pixels you want. We’ll delve deeper still, into how you can use masks and extractions in Photoshop to select image elements no matter how complicated they or their backgrounds may be. We will also take a trip through the program’s Filter menu, examining the different corrective, destructive and effect filters you can use. And we’ll finish up with a discussion of Photoshop’s layers, which can be used to keep components of your images apart.

Brushes

Photoshop is an image editing program at its core, but the program comes with a full compliment of painting tools. Even if you don’t plan to paint much in the program, it’s a good idea to spend some time getting to know the Brush Tool and its cousin, the Pencil Tool. These tools come in handy
when you're working with masks, but they're also good to know for those times when you need to make small adjustments to complicated images.

The Brush Tool is found in the Toolbox. If you click on the Brush Tool and hold down on the icon, a fly-out menu will reveal the Pencil Tool as well. You can cycle between the two tools by pressing Shift-B (remember you can configure Photoshop so it doesn't require you to hold the Shift key down when cycling through tools by going to Edit > Preferences > General and deselecting the option entitled “Use Shift Key for Tool Switch”).

If you start to draw with the Pencil Tool, you’ll see there’s not too much to it. The Pencil Tool draws a crisp line with your foreground color. You can change the diameter of your line by right-clicking on your image once the Pencil Tool has been chosen. At the top of the dialog box that opens is a Master Diameter slider. Move the setting to the right to have your Pencil diameter larger, or move it to the left for a thinner line.

You can even browse through the different brush settings that appear in the lower part of the dialog box. If you click on any of those presets, the Pencil Tool will draw with that shape. One note of caution, though: a number of the preset brushes are soft. Soft brushes appear to feather out towards the edges of the line so the line isn't so hard. But the principle behind the Pencil tool is that the line drawn is always hard. If you’d like a line that flows better, you’ll want to move onto the Brush Tool, which can be softer or harder, but it will always be a little softer than the Pencil Tool.

If you switch to the Brush Tool from the Pencil Tool (Shift-B), you’ll see the difference in the stroke you draw. You may even want to try drawing a line with the Pencil Tool set to a specific diameter, then switch to the Brush Tool, duplicate the settings, and draw a second line to compare the two.

Pencil  Brush
**Drawing a Straight Line**

Depending on your skill and level of tolerance, it can be difficult to draw or paint with a mouse. Simple tasks like drawing a straight line can be difficult. Photoshop makes it easier by giving you the ability to draw a straight line using your keyboard in combination with your mouse.

To draw a line:
1. Click at the point where you want your line to begin.
2. Hold down the Shift key, and click at the point where you want your line to end. Photoshop connects the dots for you, making a perfectly straight line.
3. If you wish to draw more lines at different angles, just hold the Shift key and keep clicking. The program will draw the line from where you last clicked to the new point.

**Drawing a Perpendicular Line**

If you want to draw a straight line at a 45°, 90°, or 180° angle:
1. Hold down the Shift key.
2. Drag your cursor up, across or on an angle. Photoshop constrains the line drawn to 45° angles only.
3. If you are drawing multiple lines and don’t want your endpoint on one line to connect to the start point of the next, draw your first line as indicated above. For subsequent lines, click first with your mouse and then hold down the Shift key as you begin to drag the mouse.

**Options**

Just beneath the Menu Bar in Photoshop you’ll see the Brush Tool Options bar when you have the Brush Tool selected.

<table>
<thead>
<tr>
<th>Picker</th>
<th>Presets</th>
<th>Brush Modes</th>
<th>Brush Opacity</th>
<th>Airbrush Controls</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="brush.png" alt="Brush:" /></td>
<td><img src="mode.png" alt="Mode:" /></td>
<td><img src="opacity.png" alt="Opacity:" /></td>
<td><img src="flow.png" alt="Flow:" /></td>
<td><img src="airbrush.png" alt="Airbrush Controls" /></td>
</tr>
</tbody>
</table>

Briefly, here’s what each part of the Brush Tool Options Bar does:

- **Picker**: The Picker lists frequently used Brush presets. If you’ve created a Brush you’d like to quickly access in the future, open the Picker and click on the Create New Tool Preset icon, which looks like a piece of paper on the right side of the Picker window. The Picker will copy all of your current brush’s attributes and suggest a name for this preset. Click OK and your brush preset is now a member of the Picker family and can be quickly accessed.

- **Presets**: The Brush Presets drop down box is identical to the Presets box you can access by right-clicking on your image when the Brush Tool has been selected. At the top of the window is a slider.
that lets you quickly increase or decrease the diameter of your current brush (without changing other attributes like brush shape or softness). You can also chose one of the preset brush shapes from the scrolling list at the bottom of the window. Just click on your choice and start painting.

Presets are like a miniature version of the Brush Palette, which you can find in the Docking Well (which appears in the upper-right corner of the Photoshop interface if your screen resolution is set to 1024 x 768 or higher).

- **Brush Modes**: Brush modes are one of the features for the Brush Tool that are less painting tools than they are image enhancers. Rather than discuss the nuances between each brush mode, let’s get a quick run down of the modes by how they are grouped. Normal is the standard brush mode. Painting in Normal mode is just like painting in real life. Dissolve as a mode dithers your brush stroke, giving it a more grainy appearance. Behind isn’t available on the background layer, but if you’re on another layer, the mode will paint “behind” whatever exists on that layer, filling only areas where the layer is transparent. Clear, like Behind, is unavailable on the background layer. It’s similar to the Eraser Tool. The next four modes (beginning with Darken) blend the foreground color with the existing pixels in your image if and only if the pixel in the image is lighter than the luminosity of the color you’ve set as your foreground color. Pixels darker than your foreground color are unaffected. The opposite is true for the next four brush modes (beginning with Lighten). In these modes, blending only occurs if the pixels painted over are darker than the luminosity of your foreground color. The next six modes (beginning with Overlay) work to enhance the contrast of the pixels in your image by making lighter lights and darker darks. For each of these categories of blending modes...
Photoshop II

(whether they darken, lighten, or enhance contrast), each specific mode handles the blending in a slightly different way. Your best bet is to experiment with each to see which works for your image. Exclusion and Difference both have interesting ways of inverting the colors in your image (neither mode works well if your foreground color is black or white). The last four modes introduce the Hue, Saturation, Color (which is Hue and Saturation combined), or Luminosity of your foreground color into the pixels of your image.

- **Opacity:** Opacity is what it seems to be: you can set the opacity of your brush stroke. 100% Opacity leaves your brush at its full intensity; 50% Opacity cuts the opacity in half, allowing more of the original pixels to appear as they were before your brush stroke. Remember that you can set Opacity separately from the Blend Mode. You can brush in the Overlay mode, but set the brush’s Opacity to 60% to make the effect more subtle, more realistic.

- **Airbrush Controls:** Photoshop lets the Brush Tool behave like an airbrush. Click on the Airbrush icon on the right to turn this effect on, and make sure your brush is at least a little soft (the effect is less pronounced on harder brush settings). Now, when you paint in airbrush mode, you can pause for a moment in an area while still holding the mouse button down. Like an airbrush, the paint continues to be applied as long as you hold the button. To lessen the effect of the airbrush, decrease the Flow setting in the Options Bar.

**Selections**

Selections are at the core of what you want to do in Photoshop. Rarely do you want to apply a change to the entire image: most of the time you want to apply a change to a very specific part of your image. Selections are the way you isolate the part of your image you want to work with.

Below you’ll find descriptions of the Marquee Tools, The Magic Wand Tool, and the Lasso Tools, all of which are useful in selecting parts of an image. Not covered here is the Pen Tool and its associated tools, which take a little more patience, but which can be quite effective in selections.

**The Marquee Tools**

The Marquee Tools are the first and most basic selection tools in Photoshop. You have four Marquee Tools, only two of which you’ll use regularly:

- **Rectangular Marquee Tool:** Just as it sounds, this tool will create a rectangular selection whenever you select the tool and drag. If you
wish to make a perfect square, hold the Shift key before or while you drag with the mouse.

- **Elliptical Marquee Tool**: Hidden just beneath the Rectangular Marquee Tool, this tool will select in an elliptical pattern. Hold the Shift key before or while you drag with the mouse for a perfect circle.

- **Single Row Marquee Tool** and **Single Column Marquee Tool**: These two tools are rarely used, but they can select a row (or column) one pixel high (or wide) by however many pixels wide (or tall) are in your image. This can be useful if you want to trim your image by a sliver, or if you’d like to have some kind of border, even if it is only one pixel in dimension.

As a sign of indicating how little you’ll use the Single Row or Single Column Marquees, Photoshop doesn’t even include them in the cycle of tools you’ll see when you press Shift-M to invoke the marquee tools – you’ll cycle between the Rectangular Marquee Tool and the Elliptical Marquee Tool only.

**Options**
With either the Rectangular Marquee or the Elliptical Marquee, you’ll have a set of options to consider on the Options Bar (just below the Menu Bar). In addition to a Preset Picker, which stores commonly used selection settings, you can click on one of four icons so that each time you work with the tool, it
1) creates a new selection, 2) adds to the existing selection, 3) subtracts from the existing selection, or 4) leaves only the intersection between the two selections left.

You can also choose to feather your selection, which partially picks pixels on the perimeter of your selection. This can soften the effect of whatever you do to the selected area, or produce a feathered border around your selection if you are moving the selection to another image.

Finally, you can set a style for your selection. **Normal** is the default setting. When you drag with Normal as your style, you have no constraints in the dimensions of your selection. **Fixed Aspect Ratio** allows you to specify a width and a height ratio that your selection will keep regardless of the size of your selection. I use this option when I want to crop an image to a common photo size, like 4 x 6, or when I want to make the image fit neatly as a desktop background. Here’s a hint: for some reason, Photoshop won’t let you specify a width or height ratio greater than 999.999. So if you want to have an image that will work at 1024 x 768, you can set the ratio to 10.24 x 7.68 or 102.4 x 76.8. As long as you keep the ratio right, Photoshop will
work with you, despite the number limitation.

Last but not least you can set the style to *Fixed Size*. This is similar to Fixed Aspect Ratio in that you must specify a height and width, but it’s different in that the size is fixed at exactly those dimensions. There’s no ratio, no scaling up and down. Once you’ve clicked, your preset selection appears, and it’s up to you to decide where to put it.

The Magic Wand Tool

The Magic Wand Tool is just that: it can magically select pixels, saving you lots of time. Unfortunately, it can be a blunt tool at times. You’ll find it ineffective when working with a complex image. Nonetheless, let’s take a quick look at the Magic Wand.

When you select the Magic Wand Tool, your cursor changes to the Magic Wand icon. Click on an area inside your image, and magically a selection is made. To master the Magic Wand, you’ll need to spend some time exploring the tools options.

Options

Just as with the other selection tools, Photoshop provides you with a Preset Picker and with icons that allow you to make new selections, selections that add to existing selections, selections that subtract from selections, and selections that produce only intersections between selections. Control of the Magic Wand begins with the *Tolerance* setting.

By default, Tolerance is set to 32. When you click with the Magic Wand Tool in an image with this Tolerance, Photoshop will select pixels that are within 32 levels of brightness and 32 levels of darkness of the pixel you clicked upon. To select more levels of brightness, increase the Tolerance (the scale is from 0 to 255). To decrease your selection, lower the Tolerance.

Check the *Contiguous* checkbox if you only want to select pixels in your Tolerance range if they are connected to one another. If you want to select pixels across your entire image even if they’re surrounded by dissimilar pixels, uncheck the Contiguous checkbox. This can be effective if you’re trying to select a sky that’s interrupted by things like trees or buildings.

Finally, the Magic Wand can go beyond its own layer to consider all layers in your image. Click *Use All Layers* to transcend and select pixels wherever they are, or leave the box unchecked to stay on your current layer only.
The Lasso Tools

As far as selection tools go, the Marquee Tools and the Magic Wand Tool are a good start. But each is limited when it comes to selections of even moderate complexity. The Lasso Tools allow you to make your selection by drawing around what it is you want – you really do rope your selection in as the tool’s name suggests. Whenever you’re working on a selection that’s not rectangular, elliptical or a selection of a specified luminosity, the Lasso Tools are likely to be your first choice. Let’s take a look at each of them.

The Lasso Tool
The Lasso Tool is a free-form selection tool. Just drag your mouse around the item you want to select. Note that with all of the Lasso Tools your goal is to define the perimeter of the selection. If you release your mouse button before you’ve closed your selection, Photoshop will complete the selection for you by drawing a line between the point where you stopped dragging and the start point of your selection. That can be useful under some circumstances, but for the most part you’ll want to exercise complete control over your selection by closing it yourself.

The Polygonal Lasso Tool
The Polygonal Lasso Tool lets you create selections with straight lines. Click to define your start point, then move your mouse (without holding the button down) to define how long the line segment will be. Click again to set a corner point, from which you can define the next segment of your selection. Continue around your selection until you return to your start point. When you hover your cursor over the start point, you’ll see a small circle appear at the lower right-hand corner of the cursor to indicate that clicking at that pixel will complete your selection. If you get too carried away with the tool, and your selection begins to look like a spider web instead of a selection, you can press the Escape key to get rid of what you’ve done so far. Alternatively, you can double click anywhere on the image to complete your selection, then deselect (Ctrl-D/Command-D) the selection to make it go away.

One of the nice things about the Polygonal Lasso Tool is how it is not limited to your image when making a selection. This can be useful when you want your selection to extend to the absolute border of the image. To select beyond the image, you’ll want to expand the image window so it is larger than the image being displayed. Usually this can be done by dragging the lower right corner of the image window out.

Switch!
You can alternate between the Lasso Tool and the Polygonal Lasso Tool by holding down the Alt key (Option key on the Mac) while you select.
If you’re using the Polygonal Lasso Tool and wish to invoke the Lasso Tool, hold down the Alt key and begin dragging with your mouse (holding down the mouse button, just as the Lasso Tool requires). Let go of the mouse button to return to the Polygonal Lasso Tool.

If you’re working with the Lasso Tool and want to draw a straight segment, hold down the Alt key and begin clicking to set the corner points between your segments.

It can take a little practice to get the switching technique right, but you’ll find it useful to switch between these two tools on the fly when making your selections.

The Magnetic Lasso Tool
Both the Lasso Tool and the Polygonal Lasso Tool give you powerful ways to draw the line between what you do and don’t want to select. Unfortunately the trade-off for power is that you have to be careful as you draw your selection: precisely defining the edge of an object in an image can be difficult to do.

The Magnetic Lasso Tool allows Photoshop to help you find the edge of your selection. You begin by clicking on a start point, then move your mouse around the border of your intended selection without holding the mouse button down. Photoshop finds the edges for you and places anchor points along your selection, defining the edge as it goes.

This tool works best when the edge of your intended selection is distinct all around. If other objects interfere with your selection, the Magnetic Lasso Tool will likely make some mistakes.

You may also note that dragging your mouse slowly gives the program more time to find the edge of your selection than if you quickly race around the border.

Options
With all three of the Lasso Tools, you’ll find the Options Bar contains a Preset Picker, controls to create new selections, add to selections, subtract from selections or select the intersection of selections. You’ll also be able to determine if your selection should be feathered, which gives it softer edges that seem to fade into your background. Typically I don’t feather a selection unless I want that effect. I do, however, leave the Anti-aliased checkbox checked. Anti-aliasing keeps your selection from having sharp, jaggy edges.

The Magnetic Lasso Tool has four additional Options for you to consider:

- **Width**: When you draw with the Magnetic Lasso Tool, the Width
setting determines how many pixels away from the cursor it can look to find the edge of your selection. Increasing the value lets the tool look further away from your cursor, but that means you lose a little control over the edge of your selection.

- **Edge Contrast**: Use Edge Contrast to tell Photoshop how much contrast there has to be between the pixels to be included in your selection from those excluded. If you’re having trouble getting the edge of your selection right, you may want to raise the Edge Contrast value. Then again, you may be better off cleaning up your selection with another tool after your initial selection is done. For more on that, see *Combining Tools*, below.

- **Frequency**: The Frequency value determines how often Photoshop should be placing points along your selection path. The more points you have, the more carefully defined your selection will be. If your image has a smooth edge, you can use lower Frequency values; if your edge is complicated, you may want to raise the Frequency. Remember also that you can click at any point along your selection path to set a point with the Magnetic Lasso Tool. It’s better if the tool can do the job by itself, but you do have the option.

**Combining Tools**

When you’re working with selections, you have two competing goals: you want your selection to be as accurate as possible, but you want to spend as little time as possible creating that accurate selection. Sometimes the nature of the job you’re working on requires the selection be perfect, other times you may be able to get the job done quickly without greatly affecting the quality of your final image.

Almost always, though, you’ll find that you’ll need to work with more than one selection tool to get the job done. A good technique is to use a tool that will quickly produce a loose selection around your intended pixels, and to make additional passes refining your selection, adding and removing pixels until you are satisfied.

All of Photoshop’s selection tools allow you to add or delete pixels from the existing selection through the use of one of two different keys. With any of the selection tools, once you’ve made your first selection, you can hold the Shift key when you make your second selection, and Photoshop will add your new selection to the existing one. To subtract from a selection, hold the Alt key (or the Option key on a Mac) to subtract from a selection. You can also use the buttons in the Options Bar for any of these tools to choose your selection behavior, though you have to remember to reset those values when you’re done.
The Select Menu

Once you’ve got your selection, you have more choices to explore in Photoshop’s Select Menu. Let’s run down the list of choices:

- **Select All:** If you want everything in your image to be selected, this is your option.

- **Deselect:** Perhaps the most used option on the Select Menu, Deselect clears your image of all selections. This one is so useful, I recommend taking the time to learn the keystroke for the command: Ctrl-D (Command-D on the Mac).

- **Reselect:** If you’ve just deselected something you didn’t mean to deselect, you can bring back your selection with Reselect. Another, perhaps easier choice is to go to your History palette to revert to the step before you deselected, but the Reselect command will work even after you’ve used other (non-selection) tools. If you don’t want to undo what you’ve done, but want that last selection back, Reselect is the way.

- **Inverse:** As I mentioned before, selecting in Photoshop is always a balance between accuracy and speed. You may find it easier to select everything in your image except the selection you want to have. In that case, use the Inverse command to select the opposite of whatever’s currently selected.

- **Color Range:** This tool works a bit like the Magic Wand Tool, but it offers some nice features you won’t find with the Magic Wand. When you click on Color Range… a dialog box opens with a smaller version of your image or selection. At the top of the window you’ll see a Fuzziness slider, which is similar to the Magic Wand’s Tolerance: higher Fuzziness includes more colors in the selection range, lower Fuzziness means a tighter color range is selected. As with other selection tools, you can hold down the Shift key to add to your selection, or the Alt key (Option key on the Mac) to subtract from your selection. One significant difference between the Magic Wand and Select’s Color Range is that you can see your selection grow brighter as you select your pixels. You can also change Fuzziness on the fly, whereas Tolerance has to be set for each sampling with the Magic Wand.

- **Feather:** If you’ve made your selection without feathering, you can feather your selection using this option. When invoked, you’ll be asked for a pixel range for your selection to be feathered. Keep in mind the dimensions of your working image: if it’s quite large, a one-
pixel feathering will probably not be visible.

- **Modify > Border:** If you want just the border around your selection, and not the entire selection itself, use the Modify > Border command to isolate just the border of your object. When you click on Modify > Border, you’ll be asked for the width (in pixels) you’d like for your border. Click OK to create the border selection.

- **Modify > Smooth:** If your selection has more corners, or is more jaggy than you’d like, Modify > Smooth will smooth your selection. Again, you’ll be asked to supply a width that the program can use to smooth your selection. Higher values mean smoother selections, but be careful you don’t begin to include unwanted pixels in your selection.

- **Modify > Expand:** If your selection has the right shape but you’d like it to be larger, Modify > Expand will increase your selection by however many pixels you choose.

- **Modify > Contract:** Complimenting Modify > Expand, Modify > Contract does the opposite, shrinking your selection by the number of pixels specified.

- **Grow:** You can grow your selection according to the Tolerance level you’ve set for the Magic Wand Tool by choosing Grow from the Select Menu.

- **Similar:** Similar also works like the Magic Wand Tool, but with the Contiguous checkbox unchecked. Similar pixels throughout the image are selected, regardless of location.

- **Transform Selection:** If you’ve got a selection but would like to change it (change its scale, height, width, or rotate the selection), you can do so using Transform Selection.

- **Load/Save Selection:** Finally, you can save a selection within the image. Selections become new channels in the Channel palette. For example, if you are working with an image in the RGB color space and you save a selection, the selection will be the fifth channel to appear in the Channel palette (there’s already one for RGB combined, for Red, for Green and for Blue). Note, however, that not all image formats will save additional channels. To be safe, save your images in the TIFF format (with LZW compression to save some file space) or Photoshop’s native PSD format.
There’s one other nice feature in Photoshop that’s not listed on the Select Menu. You can hide your selection border by pressing Ctrl-H (Command-H on the Mac), and redisplay the selection border by pressing Ctrl-H again. Often the “marching ants” are a distraction, and it’s nice to know you can hide them without deselecting.

**Masks & Extractions**

As effective as the selection tools can be, they aren’t as powerful as masks. Selection tools will draw borders around objects based on what you see, or based on the edges Photoshop can detect in an image.

Masks are essentially grayscale images that Photoshop uses to calculate whether something is in or out of a selection. Since Photoshop has so many tools to help you work with images, you’ll find masks to be a powerful way of selecting even the most complicated components of an image.

Before we explore two ways of masking, a little theory. In masks:

- White pixels are selected
- Black pixels are not selected
- Gray pixels are partially selected

That last one takes a little getting used to, but if you think about how you can feather a selection, think of Photoshop using a gradient of white to black to determine which pixels are in or out.

If you can accept the concept of white, black and gray pixels determining what’s selected, you’re ready to being working with masks.

**Quick Mask Mode**

The easiest way to mask an image is to use the Quick Mask mode. You can easily jump in and out of the mode by clicking on the Quick Mask mode button or by pressing Q (for Quick!) on your keyboard. Q will toggle you in and out of Quick Mask and Standard Mode – it’s one of the keystrokes worth remembering.

When you first invoke the Quick Mask mode, nothing appears to have changed. In fact, you’ve entered an alternate mode of Photoshop where painting with the brush or working with any of the tools will not change the image itself, but will add or subtract from the mask being generated.

Before starting, you should first make sure you have the foreground and background colors set to the default black on white (remember since masks are grayscale images, any colors other than black and white will be considered a shade of gray and mean that you are only partially selecting
photoshop ii

your pixels). You can reset your colors either by clicking on the black-on-white icon just beneath the color display on the Toolbar, or by pressing the letter D (for Default colors) on your keyboard.

When you paint with black, you will notice that instead of black onscreen you see a translucent red. Quick Mask mode shows deselected pixels in a translucent red by default so you can still see the image beneath your mask. If your image has lots of red in it, you may want to change the Quick Mask color to a less common color in your image. To change the Quick Mask color, double click on the Quick Mask icon in the Toolbar. You'll note that you can change whether the colored area is selected or deselected (the default), and you can set the opacity of your color in case 50% opacity isn’t sufficiently transparent for you to do your work.

Selected areas aren’t white in Quick Masks: they’re clear. All of this is for appearance sake, so you can work with your image easily. So to recap, when you’re using the default colors in Quick Mask mode, what’s selected is clear, what’s deselected is red at 50% opacity, and what’s partially selected is somewhere in between. With that said, you can begin to paint in your image to make your selection as precise as your eye can be.

Changing Brush Sizes Quickly

Usually when I’m working in a Quick Mask, I use a hard brush so my selection will be distinct and not feathered at all. But I need to move quickly sometimes from a large brush to a smaller one, and I don’t want to have to invoke the Brush Tool Preset Picker every time I want to change. Photoshop gives you keystrokes to increase or decrease your brush size: use the Left Bracket key (‘[’) to decrease the size of your brush, or use the Right Bracket key (‘]’) to increase the size. All of this happens without changing your brush shape or softness.
Swapping Black and White

Another useful shortcut is one that allows you to switch your foreground and background colors quickly. Just press the letter X to switch your foreground and background. You can toggle this as much as you like.

Using both the brush size shortcuts and the color-swapping shortcuts makes it much easier to paint my mask quickly.

As you work on your mask, be sure to jump in and out of Quick Mask mode. When you go back to the Standard mode, the border of your mask becomes the marching ants of your selection. Often you’ll notice something toggling back and forth between the two modes that you might miss in either one.

Mask Channels from Your Image

The challenge you will eventually find is one where your eyes fail you, and you cannot detect the precise edge of the selection you wish to create. Or perhaps your selection is so intricate, with wisps of hair (the curse of photorealistic image editing) flying out. In these situations, mask channels created from your image are the solution. Creating a good channel mask takes patience and several steps, but I think you’ll agree that it helps you find edges you can’t identify in other ways.

What follows is a technique from Deke McClelland, author of the Photoshop Bible, one of the most comprehensive and fun to read reference books for any software program I’ve encountered.

Let’s use a specific example to understand how mask channels work. Below is a detail from a picture showing two geese in the water. I would like to take the goose in the foreground to use it in another image. The challenge is that the goose’s head is difficult to define against the other goose.

We begin isolating our goose by taking a look at the Channels palette, which sits with the Layers palette in the lower right hand corner of the program interface by default. The Channels palette shows us the image in RGB mode, with the Red, Green and Blue channels shown independently
Photoshop stores each channel as a grayscale image. White pixels represent your channel color at its full intensity, black indicates an absence of that color in the channel.

Often when you look at an image on a channel by channel basis, you begin to see detail that’s obscured when channels are combined. There’s no right channel to pick: you want to look at each to determine which most clearly defines the edges around the item you want to select. When I click on the Red, Green and Blue channels one at a time, I see more detail about the outer edge of the goose’s head in the Green channel.

I can create a new channel based on the Green channel by dragging it down to the Create New Channel button (which looks like a piece of paper, second from the right at the bottom of the Channels palette). Photoshop automatically names my new channel Green Copy (you can double-click on the channel name if you’d like to rename it).

With my new channel created and selected, I’m ready to start making my mask. The principles of masking we discussed earlier still apply: white pixels are selected, black pixels are deselected, and gray pixels are partially selected. If the detail you wish to select is only a small part of the overall image, you might want to start by creating a rectangular or elliptical selection around the item. With the selection made, choose Select > Inverse so that everything except the detail you want is selected.

Now you want to fill in the inverse selection with black so it’s out of your way. Make sure your colors are at the default black on white (press the D key to reset your colors to the default), and choose Edit > Fill. You’ll be asked whether you want to fill with the foreground or the background color (foreground is perfect if you’ve reset to the defaults). Leave Blending Modes and Opacity as they are and click OK to fill in most of your image with black.

Choose Select > Inverse again so your detail is once again selected. On the Filter Menu, choose Filter > Other > High Pass. The High Pass filter is designed to bring out the edges in an image, and that’s just what we want to do next. You can increase the radius setting to more clearly delineate the
edges of your detail. Keep in mind, though, that a higher radius setting usually results in a less precise selection in the end. For my goose, while a radius of 20.0 pixels seems great, I figure I can get my selection done well with a radius of 10.0 pixels.

About now you may be wondering whether all of this filling and high passing is having a destructive effect on your image. Happily the answer is no. In an RGB image, only the red, green and blue channels display. Other channels contain information, but they don’t have an effect on what displays. You can, if you choose, take a look at the RGB channel to see this is true. If you then click on the missing eye in the Green Copy channel, what appears onscreen is your image in Quick Mask mode.

That diversion aside (make sure you’re back to working on just the Green Copy channel), one last step and we’ll finally be ready to get down to work. Go to Image > Adjustments > Levels (or press Ctrl-L / Command-L) to bring up Photoshop’s Levels dialog. In this box, you’ll see that the High Pass filter has pulled the black, gray and white values all together in the image. Beneath the Levels chart are three sliders: one on the left for black, one in the center for gray, and one on the right for white. In the Levels dialog, everything to the left of the black slider is pure black, everything to the right of the white slider is pure white (regardless of the actual color distribution in the original image). By pulling the black and white sliders to the center (see image below), I increase the contrast even further and make it easier to spot the edges of my goose.
With the edges more cleanly defined, we want to go in and paint our goose white and paint everything else black. I can pick up my brush tool and start painting. Since black is still my foreground color, I’ll start painting outside the goose. I can use the Left Bracket and Right Bracket keys to quickly decrease or increase the size of my brush as I work. When I need, I can switch my foreground and background colors by pressing X as I continue to set what is in and out of my mask’s selection. I can also zoom in on my image (Ctrl+- or Command+- on a Mac) to see things close up.

When I’m done, I have a black and white image of the goose. To turn my mask into a selection, all I have to do is go back to the RGB Channel and Ctrl-Click (Command-Click) on the Green Copy channel.

And that’s it. Once you’ve got your selection through your mask channel, you’re ready for whatever comes next (see Fun with Selections and Masks for some suggestions on what to do with a selection once it’s been defined).

Remember that if you save your working file as a TIF or PSD file, the extra channel you’ve created will be saved too. Destination formats like JPG and GIF don’t preserve unseen channels.

**Extractions**

One last tool to help you select parts of an image before we move on: the Extract command, found under the Filter menu, is a fairly effective and quick way to extract your desired element from its background.
When you invoke the Extract command, a new window opens that covers up the entire Photoshop interface. You won’t need any of Photoshop’s other features until you’re done with the Extract command.

The tools you’ll use are along the left side of the interface. The topmost tool is the Edge Highlighter Tool, which you will use to draw around the outside of the selection you wish to make. There should be no pixels between what you want to select and the Highlighter: just draw around the subject. If part of your selection-to-be extends beyond the image, you don’t have to highlight around that: just be sure that there are no other gaps in the border between your selection and the rest of the image.

You have one level of Undo in the Extract window. If you realize you need to go back more than one step, your only real choice is to hold down the Alt key (Option key on the Mac) and click the Reset button (when you hold down the Alt key in a dialog window in Photoshop, Cancel becomes Reset).

With your subject highlighted, you are now ready to use the Fill Tool, which looks like a paint bucket, to fill the area of what it is you want to select.

With your edge highlighted and your selection filled, you’re ready to click on the Preview button to see how the Extract command would create your selection. After a few moments, your selection should appear against a transparent background (transparency in Photoshop is denoted by a white and gray checked pattern). You can zoom in on the preview (Ctrl+) and drag the image around (hold the Space bar and drag) to see how well the selection has been made.

Additional tools on the left are available to help you retouch your extraction before returning to Photoshop proper. Beneath the Eyedropper Tool (which is disabled in Preview mode) is the Cleanup Tool. Select this tool and paint anywhere you wish to create transparency (i.e. anywhere the
Extract command missed). You can also use the next tool down, the Edge Touchup Tool, to restore pixels that have been deselected by the command.

When you’ve done all the touching up you want, click OK to return to your newly extracted image in Photoshop.

**Fun with Selections & Masks**

As involved as selections, masks and extractions can be in Photoshop, they’re only half the fun. Once you’ve got your selection defined the way you want, it’s time to manipulate your image. Below are just a few things you can do to a selection.

**Adjustment Layers**

Adjustment layers are a way for you to adjust the brightness, contrast, or color of your selection. Recently I’ve noticed how all the clothing catalogs and web sites show you the same shirt in different colors. Easily done in Photoshop, once you’ve selected just the shirt. Let’s start by looking at our original image of a young man wearing a black shirt, which I’ve already selected.
We'll change the color of his shirt (and nothing but the shirt) by choosing Layer > New Adjustment Layer > Hue and Saturation. When you make this choice, you'll be given the opportunity to name your new layer – I usually just click OK so I can get down to business altering the color.

The Hue/Saturation dialog box appears, and conveniently the marching ants of your selection are hidden (that way you'll be able to see your changes as they will appear when you're done). By default, Hue, Saturation and Lightness are all at the midpoint on their respective sliders. Hue can be adjusted 180° in either direction (giving you full access to the 360° world of color); Saturation and Lightness can go on a scale to 100 in either direction. For a black shirt like this one, I'll need to make adjustments to all three sliders to change his shirt color believably. In this case, I set the Hue to +141 the Saturation to +86, and Lightness to +9 to create a red shirt.
What’s nice about Adjustment Layers is that they leave the actual pixels of your original image untouched. If I turn off the visibility of the Adjustment Layer, the shirt immediately reverts to black. I could produce as many Adjustment Layers as I need – one for every shirt color in my hypothetical catalog.

**Copying and Moving Selections**

Another powerful thing you can do with Photoshop is to copy your selection so you can reproduce that part of the image in another place. Once you’ve defined your selection, it’s just a matter of copy and paste, as with all programs. Edit > Copy will copy the pixels you’ve selected, and Edit > Paste will paste them.

When you paste a selection into the same image, the new copy appears on its own layer in the exact same location as your original selection. If you’re not watching the Layers palette, you might miss the fact that your paste has taken place.

Once your selection has been pasted, you can use the Move Tool (V) to move your copy to another part of the image. Returning to our geese example from before, it’s easy enough to copy our goose, paste it, and move it just a little so instead of two geese we now see three.

Of course, our eyes are trained to look for patterns, so most people examining this image would guess there’s something fake about this picture. To differentiate the cloned goose from the original, you can Transform your copy so it appears different from its source.

For my goose, I chose Edit > Transform > Flip Horizontal, then I chose Edit > Transform > Perspective. To change the perspective I pulled down the upper left corner of the selection, making the goose’s tail smaller than the original. This also had the effect of changing the angle at which the goose was swimming. Finally I chose Edit > Transform > Scale, and I held down the Shift key while dragging the upper right corner inward so the
goose would scale down proportionately. The result is at least slightly more realistic than what I had to start.

Another option with selections is to drag them into other images. With my original goose image open, and my selection active, I can use the Move Tool (V) to drag the goose into a second image.

As before, I'll want to make some changes to the image to make it seem more realistic in this new environment.

I'll start by creating a shadowy reflection of the goose in the water. To do this, I first drag the layer containing the goose to the New Layer button in the Layers Palette. This will duplicate the goose layer so I'll have a copy of my goose.

Next, I'll flip my second goose upside-down by choosing Edit > Transform > Flip Vertical. Things aren't lined up yet, so with the Move Tool selected, I'll press the down arrow on my keyboard to nudge the upside-down goose until it's below the “real” goose. Note that I'm not using my mouse to drag the goose. When I flipped the second goose, Photoshop maintained the horizontal coordinates of the original, so if I can just nudge the new goose
Photoshop II

down, things should line up perfectly.

To make the upside-down goose a reflection instead of an upside-down goose, I'll go to the Layers palette and experiment with the different Blend Modes. Overlay seems to give me the closest thing to what I think a reflection might be in this environment, but I'm going to also lower the Opacity to 50% so the reflection is less obvious.

Last but not least, I'd like to use Transform again to make the goose a bit smaller. I need to make sure that both the "real" goose and the "reflection" are both reduced equally, so I'll link the layers together so what happens to one happens to the other. To link a layer in Photoshop, select one layer (the selected layer is "highlighted", and a paint brush symbol appears next to the eye symbol). With one layer selected, click in the empty box (where the paint brush would appear if that layer were selected) on the layer you want to link.
Photoshop II

Now I can go to Edit > Transform > Scale, and shrink both the “real” and the “reflected” geese. Once again I’ll hold down the Shift key while I pull the upper right hand corner inward, so the scaled down goose keeps its proportions. I move my goose with reflection into place, and I’m done.

Defringe
Occasionally when a selection is copied into another environment, you’ll see fringe pixels that you might not have noticed in the original image. To get rid of the edge, choose Layer > Matting > Defringe. You’ll be asked to enter the number of pixels to shave off your layer, and you may have to experiment (and Undo) until you find the right setting.

Filters
Filters can enhance your image, or they can through effects transform your image into something altogether different. Depending on your artistic interests, you may find only a few filters to be worth their while, or you may find yourself spending hours exploring all the permutations of the effects filters.

We’ll start with a look at three fundamental filters almost everyone should know, then we’ll move on to look at a sampling of effects filters.
Corrective Filters

**Sharpen > Unsharp Mask**
We’ll start with what is in my opinion the most important filter: Unsharp Mask. I’m not certain why it’s called Unsharp Mask, but it’s the best method for sharpening your image.

Unsharp Mask lives under the Filter > Sharpen submenu, along with the other sharpening filters (Sharpen, Sharpen Edges, and Sharpen More). Unsharp Mask is perhaps the most useful of the four since it’s the only one that gives you control over the sharpening process.

You’ll want to use Unsharp Mask to restore clarity to an image (or a selection) after you’ve resized. Photos taken with digital cameras can also sometimes benefit from sharpening, even if you aren’t resizing.

When you invoke the Unsharp Mask, a dialog box appears. In the window you’ll see part of your image with the filter applied based on the settings at the bottom of the window. If the Preview checkbox is checked, you’ll also see the filter applied to your image. As you work with the settings, keep your eye on your image as each tweak is reflected. It’s also a good idea to uncheck and recheck the Preview box so your can see your image without the filter and with it again, to make sure you haven’t gone too far.

There are three settings to consider when using Unsharp Mask:

- **Amount**: Use the Amount setting to determine how pronounced you want the sharpening effect to be. For most sharpening, I choose 50% or 100%. For pronounced sharpening you can go as high as 500%.
• **Radius:** The Radius setting determines how wide the enhanced edges should appear in your image. Usually I use a Radius between 0.3 and 1.5, though I have used a Radius as high as 2.0 for very large images. If you think about it, the larger your image is, the higher you may want your Radius to be. A 1.0 pixel Radius can be quite strong on a 320 x 240 pixel web image, but almost unnoticeable on a 3200 x 2400 pixel image, which may be intended for high-resolution printing.

• **Threshold:** Threshold works in a way that’s similar to Tolerance with the Magic Wand Tool – use Threshold to tell Photoshop how many levels of difference in brightness a pixel must have to its neighbor to qualify for the sharpening effect. A low number means that more pixels will be sharpened, while a higher number means that fewer pixels will be sharpened.

Most of the time, I'll set Amount set to 50% or 100%, Radius between 0.3 and 1.5, and I'll leave Threshold set to 0. I'll qualify that by saying that most of the work I do is for the screen: if you work primarily in print, you will most likely use a higher Radius and possibly a higher Amount.

**Blur > Gaussian Blur**
Sometimes you want to bring clarity to an image, other times you want to blur out parts that may be too much in focus. Gaussian Blur is by far the most popular of the blur filters.

Let’s say we wanted to combine two images: one of a nice house in the country, the other of a content and confident woman (you’ll remember the woman from the Extract example, above).
We want to bring the woman into the foreground of the house image. Since it appears the light is coming from the right in the picture of the house, I'll choose Edit > Transform > Flip Horizontal to flip the image of the woman before dragging her into the house image.

The house in the back already seems a little out of focus, but I'm going to select the Background layer and choose Filter > Blur > Gaussian Blur to take it a little more out of focus. Since I'm working with a fairly large image, I'm setting the Radius to 5.0 pixels on the Background layer.
Photoshop II

This takes it out of immediate focus, and hopefully draws the viewer’s eye to the woman. It unfortunately doesn’t quite show at this small a resolution, but hopefully you get the sense of what the tool can do.

In addition to blurring an entire layer, you can use Gaussian Blur to soften the focus on selections. Fashion photography will often blur skin to homogenize the tone of the skin, while leaving detail such as eyes and hair sharp.

**Noise > Median**

If your original image has dust, scratches or other small gritty imperfections, you may want to explore the Noise > Median filter, which samples pixels in a specified radius to determine the average colors, which are then applied throughout the image, smoothing away the grit with hopefully minimal impact on the clarity of your picture. In truth, Median does take away detail, though it does it in a way different than Gaussian Blur.

I know of two techniques you might consider to remove imperfections while keeping as much detail as possible in your image.

The first technique is to apply the Noise > Median filter to a duplicate layer of your original layer, then use one of the layer Blend Modes to combine the
two layers, bringing back detail that’s lost using the filter alone. Also consider using Opacity to fade the effect of Median and the Blend mode against the original layer.

The second technique is similar in effect, but different in approach. Apply the Median filter, then go to Edit > Fade Median. You’ll be able to fade the Opacity of the filter without having to create a duplicate layer.

My preference would be the first option, since it leaves two layers I can adjust in the future if need be.

Effects Filters

There are dozens of effects filters. Some make photos seem more like paintings. Others twist and disrupt the image in ways almost unimaginable. Here is a quick look at a sampling of effects filters. Experimentation is the way to get the most out of effects filters: rather than prescribe specific settings for any of these, I’ll focus on exploring some of the different effects you’ll find.

Liquify
Liquify is like a trip through the fun house. When you pick this option from the Filters menu, a new window opens and you can drag with your brush to distort the features of your original. After a few quick strokes I can take the photo of the gentleman we used to change the color of his shirt:

Not necessarily realistic, but if done with some care, you can make very subtle distortions to an image.
The Original Image
Here’s our original image for you to compare with what different filters can do.

![Original Image](image_url)

Artistic > Watercolor
As a representative of the Artistic submenu, Watercolor demonstrates that many of the Artistic filters can make a photograph appear like a painting or drawing.

![Watercolor Image](image_url)
Distort > Diffuse Glow
While I like to think that almost all filters distort in some way, the Distort submenu is devoted to filters that generally distort the image as a whole rather than on a pixel-by-pixel basis. One nice exception is Diffuse Glow, which can create a nice atmosphere for some images.

Noise > Add Noise
We use tools like Median or Gaussian Blur to clean up grit that gets into our images. Sometimes we want to add grit to an image for effect.
**Sketch > Halftone Pattern**  
If you’d like your image to appear as if it were in a newspaper...

![Halftone Pattern Image]

**Stylize > Glowing Edges**  
For a modern, electric look.

![Glowing Edges Image]

**Texture > Texturizer**  
Photoshop comes with a small set of textures that can be applied to an image. In this case, I chose a brick texture, as if my picture were on a wall.

![Texturizer Image]
The effects go on and on. Depending on your interest in effects such as these, you may want to take a few hours to explore all of the different filters and their settings.

**Layers**

We’ve already covered layers as we’ve worked with Photoshop. Let’s review some of what we already know and look at how we can use layers in other interesting ways.

**The Background Layer**
The Background layer is the foundation upon which you build. Since it is the “bottom” layer in your image, there are some restrictions on the Background layer that don’t apply to other layers.

First of all, the Background layer can’t have transparency. Most image formats don’t support transparency, and there are obvious issues with handling transparency when moving to the print world. You can make the bottom layer in your image transparent by selecting Layer > New > Layer from Background, which will prompt you to name the new layer (the default is ‘Layer 0’). Once you’ve converted your Background layer to something else, you’ll be able to use the Eraser Tool or other tools to erase pixels on the layer, revealing transparency.

You also can’t move the Background layer. It basically violates the same law as the one we just mentioned: if you move the Background layer, you’re revealing transparent pixels. New Layer from Background will also fix this problem.

**New Layers**
You can create a new layer by selecting Layer > New > Layer, which prompts you for the layer name (which is usually a one-up number from the last layer added). If you don’t care about the name of the new layer, you can click the Create a New Layer icon, which is second from the right on the bottom of the Layers palette. The icon looks like a page with the bottom corner turned up.
Photoshop II

Copying Layers
If you have a layer you’d like to copy or duplicate, just drag the layer down to the new layer icon at the bottom of the Layers palette. All layers (including the Background layer) can be duplicated.

Moving Layers
To move a layer, just click on the layer and drag it up or down in the list of layers. Release when the layer is where you want it to be.

Deleting Layers
To delete a layer, drag the layer to the trash can icon at the bottom right of the Layers palette.

Hiding Layers
Sometimes you don’t want to delete a layer, just hide it. You can do this by clicking on the eye icon to the left of the layer. This is especially useful if you are producing a series of images that contain common elements with variations. You can make a layer visible, save the flattened image under one file name, hide the layer, make a different layer visible, save that as a separate flattened image, and so on.

Opacity and Blend Modes
Just as we saw with the Brush Tool, we can set both Opacity and Blend Modes for layers. These features work identically to the way they were described in the Brushes section, above, except the effect works for the entire layer.

Merging Layers
Layers are especially useful because you can work with one at a time without interfering with what’s on layers above and below. There are times, however, when you need to merge one or more layers together before you can finish editing your image.

Layer > Merge Down will merge your selected layer with the one beneath. Layer > Merge Visible will merge all visible layers into one. If you make some layers invisible before using this command, those layers will not be
Photoshop II

merged, and you can turn them back on after the operation is complete. Layer > Flatten Image will flatten all layers whether they are visible or not.

**Folder Sets**
As you can imagine, it's possible to have images with dozens of layers in them. Photoshop has the ability to organize layers into Folder Sets. To create a Folder Set, click on the folder icon at the bottom of the Layers palette. You can then drag layers into the folder, which simplifies your view of your layers. Just click on the triangle to the left of the Folder Set name to view the layers in the folder.

![Layers palette with Folder Sets](image)

Remember that the order of your layers, from top to bottom, determines the appearance of your image. This continues to be true when you use Folder Sets.

**Linking Layers**
As you saw in the example of the goose in the jungle, you can link layers together so that changes made to one layer affect the others. Select the first layer to be linked, then click in the square to the right of the eye icon on the first layer to be linked. Repeat for each linked layer.

![Linked layers in Layers palette](image)

To unlink layers, simply click on the chain icon that indicates the layer is linked.

**Locking Layers**
You can lock a layer in four different ways to prevent accidental edits. The
Photoshop II

four icons appear after the word Lock in the Layers palette, above where your layers display. Click an icon to protect one or more aspects of your layer, and click the icon again to turn that control off.

- **Lock Transparent Pixels**: When your layer has transparency and this option is selected, transparency is protected so that only pixels themselves can be edited. It’s a good way to make sure you’re drawing (or painting) inside the lines.

- **Lock Image Pixels**: Use this option when you don’t want any pixels (transparent or otherwise) to be edited. Moving and transforming are still possible, but most other options will be prohibited.

- **Lock Position**: The opposite of Lock Image Pixels. You can edit the image as much as you like, but moving and transformations are protected.

- **Lock All**: Prevents the layer from being edited in any way. A great way to save you from yourself.

**Clipping Groups**
Clipping groups are similar to masks. With masks, you allow a channel to affect other channels. In a clipping group, the bottom layer becomes a mask for the associated layer(s) above. For example, if you have a person on one layer, with our country house on the layer above, and you create a clipping group between these two layers, the country house can only be seen through the outline of our person.

To create a clipping group, make sure your two (or more) layers are arranged properly. Select the top layer in what will be the group, and select Layer > Group with Previous. To undo the clipping group, select Layer > Ungroup.
Closing

As you have seen, the more you dig into Photoshop, the more you'll find the program capable of accomplishing. We've seen how Photoshop is a sophisticated painting program, even though it is an image editing program at its heart. We've also seen a number of ways that the program lets you select just the pixels you want. Finally, we've explored only some of the techniques you can use with your selections, layers, and entire images that will make them better and more interesting.

If you have questions in the future, please let me know. My e-mail address is kcreamer@richmond.edu.

Resources

Web Sites

web. (http://www.richmond.edu/~creamer/web/home.html) - My take on all things web, including images, streaming media and more.


Action Xchange (http://share.studio.adobe.com/Default.asp) – now run by Adobe, this site contains thousands of Photoshop Actions (or macros) that do very useful things.

National Association of Photoshop Professionals (http://www.photoshopuser.com/) – while it costs $100 to be a member, the association magazine, Photoshop User, is alone worth the price.

Books


Videos
